add tex4ht.fls to the svn:ignore list
[openwrt/svn-archive/archive.git] / toolchain / Makefile
index ceae2269a6c82f4c1ae6d06205d8a567cde10101..e8ee24ff7ae1d62015687cab7969b86f44d65d84 100644 (file)
@@ -1,72 +1,32 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the toolchain
 #
-include $(TOPDIR)/rules.mk
+file:=${lastword ${MAKEFILE_LIST}}
+curdir:=toolchain
 
-TARGETS-y:=kernel-headers
-TARGETS-$(CONFIG_GDB) += gdb
-TARGETS-$(CONFIG_CCACHE) += ccache
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  TARGETS-y+=binutils gcc uClibc
-endif
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
+# subdirectories to descend into
+$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
-$(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
-
-uClibc-prepare: ccache-prepare kernel-headers-prepare
+# builddir dependencies
+$(curdir)/uClibc/prepare:=$(curdir)/kernel-headers/prepare
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  binutils-prepare: uClibc-prepare
-  gcc-prepare: binutils-install
-  uClibc-compile: gcc-compile
+  $(curdir)/binutils/prepare:=$(curdir)/uClibc/prepare
+  $(curdir)/gcc/prepare:=$(curdir)/binutils/install
+  $(curdir)/uClibc/compile:=$(curdir)/gcc/compile
 endif
-gcc-install: uClibc-install
-
-TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
-       @mkdir -p $@
-       @ln -sf ../lib $@/lib
-
-$(TOOLCHAIN_STAMP_DIR):
-       mkdir -p $@
-
-$(TOOLCHAIN_BUILD_DIR):
-       @mkdir -p $@
-
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(TOOLCHAIN_STAMP_DIR) $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR) FORCE
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
-
-%-compile: %-prepare 
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+$(curdir)/gcc/install:=$(curdir)/uClibc/install
 
-%-install: %-compile
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+# prerequisites for the individual targets
+$(curdir)/ := .config $(tools/stamp)
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
 
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*
+$(eval $(call stampfile,$(curdir),toolchain))
+$(eval $(call subdir,$(curdir)))