uClibc: fix ptrace header files for powerpc
[openwrt/svn-archive/archive.git] / toolchain / binutils / Makefile
index 567f88a8543abb7392e30a91359c98659e0c1cff..820b5f8efaec6408af7ecdef2de2ed6206c0bf49 100644 (file)
@@ -63,8 +63,9 @@ endif
 
 define Host/Prepare
        $(call Host/Prepare/Default)
-       ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+       ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
+       $(SED) 's, " Linaro.*,,' $(HOST_BUILD_DIR)/bfd/version.h
 endef
 
 define Host/Configure