update AVR32 binutils patches
[openwrt/svn-archive/archive.git] / toolchain / binutils / Makefile
index 2ca79d3eaf9a93054fcb650c32c50fd666977f4f..b3161b3155a3bf0db86be72dbd3b58708aa9f752 100644 (file)
@@ -25,6 +25,7 @@ BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 include $(INCLUDE_DIR)/host-build.mk
 
 define Build/Configure
+       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/
        (cd $(PKG_BUILD_DIR); \
                ./configure \
                --prefix=$(STAGING_DIR_HOST) \
@@ -33,6 +34,7 @@ define Build/Configure
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
                --disable-nls \
+               $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
        );
 endef