add md5sums for binutils & gcc and use the GNU mirror facility
[openwrt/svn-archive/archive.git] / toolchain / binutils / Makefile
index d31742125e48f2b9339fa992a56dd2e1628d8491..e6745da8eb24bab663218defbf05d8e519635878 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,24 +7,33 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
-#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
 
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
-       ftp://gatekeeper.dec.com/pub/GNU/ \
-        ftp://ftp.uu.net/archive/systems/gnu/ \
-        ftp://ftp.eu.uu.net/pub/gnu/ \
-        ftp://ftp.funet.fi/pub/gnu/prep/ \
-        ftp://ftp.leo.org/pub/comp/os/unix/gnu/ 
+PKG_SOURCE_URL:=@GNU/binutils/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+ifeq ($(PKG_VERSION),2.16.1)
+  PKG_MD5SUM:=6a9d529efb285071dad10e1f3d2b2967
+endif
+ifeq ($(PKG_VERSION),2.17)
+  PKG_MD5SUM:=e26e2e06b6e4bf3acf1dc8688a94c0d1
+endif
+ifeq ($(PKG_VERSION),2.18)
+  PKG_MD5SUM:=9d22ee4dafa3a194457caf4706f9cf01
+endif
 
-PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
 PATCH_DIR:=./patches/$(PKG_VERSION)
+
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+override CONFIG_AUTOREBUILD=
 
 include $(INCLUDE_DIR)/host-build.mk
 
+EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)
+
 define Build/Configure
+       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/
        (cd $(PKG_BUILD_DIR); \
                ./configure \
                --prefix=$(STAGING_DIR_HOST) \
@@ -33,6 +42,7 @@ define Build/Configure
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
                --disable-nls \
+               $(EXTRA_TARGET) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
        );