binutils: add support for non-pic handling and use it in the codesourcery based gcc...
[openwrt/svn-archive/archive.git] / toolchain / eglibc / Makefile
index dff7e48528daa96a8e7183b3c2dbbbcedc129085..0363dd90613d7177639443c70bec3115e98b8d66 100644 (file)
@@ -27,6 +27,9 @@ endif
 ifeq ($(PKG_VERSION),2.9)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_9
 endif
+ifeq ($(PKG_VERSION),2.10.1)
+  PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_10
+endif
 ifeq ($(PKG_VERSION),trunk)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
 endif
@@ -51,6 +54,7 @@ EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(EGLIBC_CFLAGS)" \
+       libc_cv_slibdir="/lib" \
        $(HOST_BUILD_DIR)/libc/configure \
                --prefix=/usr \
                --build=$(GNU_HOST_NAME) \