add preliminary support for the latest CodeSourcery toolchain
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index 77243c5fa4bd2c45853a5bee0278b2a5062ed19b..09ed7b80b800755c35b2548c3af134b0dcda6749 100644 (file)
@@ -60,6 +60,9 @@ else
   ifeq ($(PKG_VERSION),4.4.2)
     PKG_MD5SUM:=70f5ac588a79e3c9901d5b34f58d896d
   endif
+  ifeq ($(PKG_VERSION),4.4.3)
+    PKG_MD5SUM:=fe1ca818fc6d2caeffc9051fe67ff103
+  endif
 endif
 
 PATCH_DIR=./patches/$(GCC_VERSION)
@@ -90,11 +93,12 @@ GCC_CONFIGURE:= \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
+               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-               $(if $(CONFIG_GCC_VERSION_4_3_3_CS),--enable-poison-system-directories)
+               $(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS),--enable-poison-system-directories)
 
 ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
   GCC_BUILD_TARGET_LIBGCC:=y