Disable tls support, uClibc does not support it, and it could lead to linking failure...
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index a1d1baa4008455c6274148028d337008453f5465..57118bb119f32eba4c86f35eca32193768a2da02 100644 (file)
@@ -60,6 +60,7 @@ define Stage1/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               --disable-tls \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
@@ -93,6 +94,7 @@ define Stage2/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               --disable-tls \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );