Disable tls support, uClibc does not support it, and it could lead to linking failure...
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index d784a6084c229129a2fb5b78bc44d08b1d7e5b3e..57118bb119f32eba4c86f35eca32193768a2da02 100644 (file)
@@ -60,6 +60,9 @@ define Stage1/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               --disable-tls \
+               $(SOFT_FLOAT_CONFIG_OPTION) \
+               $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
 endef
 define Stage1/Compile
@@ -90,7 +93,10 @@ define Stage2/Configure
                --with-gnu-ld \
                --disable-nls \
                --disable-libmudflap \
-               --disable-mutlitlib \
+               --disable-multilib \
+               --disable-tls \
+               $(SOFT_FLOAT_CONFIG_OPTION) \
+               $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
 endef