fix gcc 4.2.0 compile for ppc
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index b5502bcefaf81f615d9ac413c3f5ee2690814d81..6d46f98994153710572f6a3a839aa0fd5362842d 100644 (file)
@@ -119,6 +119,7 @@ define Build/Prepare
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(PKG_BUILD_DIR)/gcc/version.c
        $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(PKG_BUILD_DIR)/gcc/version.c
        (cd $(PKG_BUILD_DIR)/libstdc++-v3; autoconf;);
+       $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(PKG_BUILD_DIR)/libstdc++-v3/configure
 endef
 
 define Build/Configure