this patch fixes toolchain parallel build, which reduces build time.
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index 3b31127b4ae6db6815fc573bc2298de964ba76c1..9c820f2feca59a81cfec96957c58a7ce9af7ca39 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -60,6 +60,9 @@ else
   ifeq ($(PKG_VERSION),4.4.2)
     PKG_MD5SUM:=70f5ac588a79e3c9901d5b34f58d896d
   endif
+  ifeq ($(PKG_VERSION),4.4.3)
+    PKG_MD5SUM:=fe1ca818fc6d2caeffc9051fe67ff103
+  endif
 endif
 
 PATCH_DIR=./patches/$(GCC_VERSION)
@@ -90,11 +93,12 @@ GCC_CONFIGURE:= \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
+               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-               $(if $(CONFIG_GCC_VERSION_4_3_3_CS),--enable-poison-system-directories)
+               $(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
 
 ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
   GCC_BUILD_TARGET_LIBGCC:=y
@@ -112,6 +116,11 @@ else
                --disable-libssp
 endif
 
+ifeq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE+= \
+               --disable-tls
+endif
+
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
   GCC_CONFIGURE+= \
                --enable-biarch \
@@ -148,9 +157,12 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
-               --disable-tls \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifdef CONFIG_powerpc
+  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \
@@ -238,7 +250,7 @@ define SetupExtraArch
 endef
 
 define Stage2/Install
-       $(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
+       $(_SINGLE)$(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(TOOLCHAIN_DIR)/usr; \