replace gcc 4.2 snapshot with 4.2.0 release (sync patches with uclibc buildroot)...
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index d0b6658143cbccf8c26e2e09589ae2c635395599..b5502bcefaf81f615d9ac413c3f5ee2690814d81 100644 (file)
@@ -23,16 +23,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=gcc
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))#"))
 
-ifeq ($(PKG_VERSION),4.2)
-PKG_VERSION:=20060709
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PATCH_DIR=./patches/4.2
-else
 PATCH_DIR=./patches/$(PKG_VERSION)
 PKG_SOURCE_URL:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(PKG_VERSION) \
        http://mirrors.rcn.net/pub/sourceware/gcc/releases/gcc-$(PKG_VERSION) \
        ftp://ftp.gnu.org/gnu/gcc/releases/gcc-$(PKG_VERSION)
-endif
        
 PKG_SOURCE:=gcc-$(PKG_VERSION).tar.bz2
 PKG_MD5SUM:=unknown
@@ -122,7 +116,6 @@ endef
 
 define Build/Prepare
        $(call Build/Prepare/Default)
-       $(SCRIPT_DIR)/patch-kernel.sh $(PKG_BUILD_DIR) $(PATCH_DIR) \*.patch
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(PKG_BUILD_DIR)/gcc/version.c
        $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(PKG_BUILD_DIR)/gcc/version.c
        (cd $(PKG_BUILD_DIR)/libstdc++-v3; autoconf;);