also ignore env directory
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index 6f2b626f38bcf0655bd11aa6cf920959c4c35598..e9598d81776083b96ae9e47008c54d8865b13453 100644 (file)
@@ -35,15 +35,12 @@ endif
 ifeq ($(PKG_VERSION),4.2.4)
   PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
 endif
-ifeq ($(PKG_VERSION),4.3.1)
-  PKG_MD5SUM:=4afa0290cc3a41ac8822666f1110de98
-endif
-ifeq ($(PKG_VERSION),4.3.2)
-  PKG_MD5SUM:=5dfac5da961ecd5f227c3175859a486d
-endif
 ifeq ($(PKG_VERSION),4.3.3)
   PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
 endif
+ifeq ($(PKG_VERSION),4.4.0)
+  PKG_MD5SUM:=cf5d787bee57f38168b74d65a7c0e6fd
+endif
 
 PATCH_DIR=./patches/$(PKG_VERSION)
 
@@ -73,8 +70,9 @@ GCC_CONFIGURE:= \
                --disable-nls \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
 
-ifneq ($(CONFIG_GCC_VERSION_4_3),)
+ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
   GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
@@ -178,6 +176,7 @@ define Stage1/Install
        # XXX: glibc insists on linking against libgcc_eh
        ( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
                [ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
+               cp libgcc.a libgcc_initial.a; \
        )
 endef
 
@@ -189,6 +188,7 @@ define Stage2/Configure
        ln -sf ../include $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/sys-include
        rm -rf $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib
        ln -sf ../lib $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib
+       $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib64)
        (cd $(HOST_BUILD_DIR2); rm -f config.cache; \
                $(GCC_CONFIGURE_STAGE2) \
        );
@@ -234,7 +234,7 @@ define Host/Prepare
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(HOST_BUILD_DIR)/gcc/version.c
        $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(HOST_BUILD_DIR)/gcc/version.c
-       (cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
+       #(cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
        $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_BUILD_DIR)/libstdc++-v3/configure
        $(call Stage0/Configure)
        $(call Stage0/Compile)