brcm47xx: fix for boardflags by xMff
[openwrt/svn-archive/archive.git] / toolchain / gcc / Makefile
index 9df43af901bad8d4d7b20529bdbf368d36f42f5b..fc31d6fe5fc8c5a29057764d318dfc86479916c8 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gcc
-PKG_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
-
-PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-
-ifeq ($(PKG_VERSION),3.4.6)
-  PKG_MD5SUM:=4a21ac777d4b5617283ce488b808da7b
-endif
-ifeq ($(PKG_VERSION),4.1.2)
-  PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
-endif
-ifeq ($(PKG_VERSION),4.2.4)
-  PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
-endif
-ifeq ($(PKG_VERSION),4.3.1)
-  PKG_MD5SUM:=4afa0290cc3a41ac8822666f1110de98
-endif
-ifeq ($(PKG_VERSION),4.3.2)
-  PKG_MD5SUM:=5dfac5da961ecd5f227c3175859a486d
-endif
-ifeq ($(PKG_VERSION),4.3.3)
-  PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
-endif
-ifeq ($(PKG_VERSION),4.4.0)
-  PKG_MD5SUM:=cf5d787bee57f38168b74d65a7c0e6fd
+GCC_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
+PKG_VERSION:=$(firstword $(subst +, ,$(GCC_VERSION)))
+GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+ifdef CONFIG_GCC_VERSION_LLVM
+  PKG_SOURCE_VERSION:=c98c494b72ff875884c0c7286be67f16f9f6d7ab
+  PKG_REV:=83504
+  GCC_DIR:=llvm-gcc-4.2-r$(PKG_REV)
+  PKG_VERSION:=4.2.1
+  PKG_SOURCE:=$(GCC_DIR).tar.gz
+  PKG_SOURCE_PROTO:=git
+  PKG_SOURCE_URL:=git://repo.or.cz/llvm-gcc-4.2.git
+  PKG_SOURCE_SUBDIR:=$(GCC_DIR)
+  HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
+else
+  PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
+  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+  ifeq ($(PKG_VERSION),3.4.6)
+    PKG_MD5SUM:=4a21ac777d4b5617283ce488b808da7b
+  endif
+  ifeq ($(PKG_VERSION),4.1.2)
+    PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
+  endif
+  ifeq ($(PKG_VERSION),4.2.4)
+    PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
+  endif
+  ifeq ($(PKG_VERSION),4.3.3)
+    PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
+  endif
+  ifeq ($(PKG_VERSION),4.3.4)
+    PKG_MD5SUM:=60df63222dbffd53ca11492a2545044f
+  endif
+  ifeq ($(PKG_VERSION),4.3.5)
+    PKG_MD5SUM:=e588cfde3bf323f82918589b94f14a15
+  endif
+  ifeq ($(PKG_VERSION),4,4,1)
+    PKG_MD5SUM:=927eaac3d44b22f31f9c83df82f26436
+  endif
+  ifeq ($(PKG_VERSION),4.4.2)
+    PKG_MD5SUM:=70f5ac588a79e3c9901d5b34f58d896d
+  endif
+  ifeq ($(PKG_VERSION),4.4.3)
+    PKG_MD5SUM:=fe1ca818fc6d2caeffc9051fe67ff103
+  endif
+  ifeq ($(PKG_VERSION),4.4.4)
+    PKG_MD5SUM:=7ff5ce9e5f0b088ab48720bbd7203530
+  endif
+  ifeq ($(PKG_VERSION),4.5.0)
+  PKG_MD5SUM:=ff27b7c4a5d5060c8a8543a44abca31f
+  endif
 endif
 
-PATCH_DIR=./patches/$(PKG_VERSION)
+PATCH_DIR=./patches/$(GCC_VERSION)
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
@@ -61,6 +87,8 @@ HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
 SEP:=,
 TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
 
+export libgcc_cv_fixed_point=no
+
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(HOST_BUILD_DIR)/configure \
@@ -74,11 +102,15 @@ GCC_CONFIGURE:= \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
+               $(GRAPHITE_CONFIGURE) \
+               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
+               $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+               $(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
 
-ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
+ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
   GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
@@ -86,6 +118,15 @@ ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
                --disable-decimal-float
 endif
 
+ifneq ($(CONFIG_GCC_VERSION_4_5),)
+  GCC_BUILD_TARGET_LIBGCC:=y
+  GCC_CONFIGURE+= \
+                --with-gmp=$(TOPDIR)/staging_dir/host \
+                --with-mpc=$(TOPDIR)/staging_dir/host \
+                --with-mpfr=$(TOPDIR)/staging_dir/host \
+                --disable-decimal-float
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),)
   GCC_CONFIGURE+= \
                --enable-libssp
@@ -130,16 +171,35 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
-               --with-slibdir=$(TOOLCHAIN_DIR)/lib \
+               --with-slibdir=$(TOOLCHAIN_DIR)/lib
+
+ifneq ($(CONFIG_GCC_VERSION_4_5),)
+  GCC_CONFIGURE_STAGE2+= \
+               --enable-lto \
+               --with-libelf=$(TOPDIR)/staging_dir/host
+endif
+
+ifneq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE_STAGE2+= \
+               --enable-tls
+else
+  GCC_CONFIGURE_STAGE2+= \
+               --disable-tls
+endif
+
+ifdef CONFIG_powerpc
+  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
 
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \
-
+               CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
+               CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"
 
 define Host/SetToolchainInfo
        $(SED) 's,TARGET_CROSS=.*,TARGET_CROSS=$(REAL_GNU_TARGET_NAME)-,' $(TOOLCHAIN_DIR)/info.mk
-       $(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
+       $(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(GCC_VERSION),' $(TOOLCHAIN_DIR)/info.mk
 endef
 
 
@@ -178,10 +238,11 @@ define Stage1/Install
        $(GCC_MAKE) -C $(HOST_BUILD_DIR1) \
                install-gcc \
                $(if $(GCC_BUILD_TARGET_LIBGCC),install-target-libgcc)
-       
+
        # XXX: glibc insists on linking against libgcc_eh
        ( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
                [ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
+               cp libgcc.a libgcc_initial.a; \
        )
 endef
 
@@ -217,7 +278,7 @@ define SetupExtraArch
 endef
 
 define Stage2/Install
-       $(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
+       $(_SINGLE)$(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(TOOLCHAIN_DIR)/usr; \
@@ -232,13 +293,17 @@ define Stage2/Install
 endef
 
 
+BUGURL=https://dev.openwrt.org/
+
 define Host/Prepare
        $(call Host/SetToolchainInfo)
        $(call Host/Prepare/Default)
-       ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+       ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
+       $(SED) 's,^MULTILIB_OSDIRNAMES,# MULTILIB_OSDIRNAMES,' $(HOST_BUILD_DIR)/gcc/config/*/t-*
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(HOST_BUILD_DIR)/gcc/version.c
-       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(HOST_BUILD_DIR)/gcc/version.c
+       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:$(BUGURL)>\2,' $(HOST_BUILD_DIR)/gcc/version.c
+       $(SED) 's,http://gcc.gnu.org/bugs.html,$(BUGURL),' $(HOST_BUILD_DIR)/gcc/configure
        #(cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
        $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_BUILD_DIR)/libstdc++-v3/configure
        $(call Stage0/Configure)