[toolchain/gcc]: llvm is marked broken for two and a half year now, nuke it
[openwrt/svn-archive/archive.git] / toolchain / gcc / common.mk
index 924ed90a63eb4b7cdc4e4cdd651d35a667038a92..0a5e6e660bf5b23e39133fa5a44cef7af49cd620 100644 (file)
@@ -25,17 +25,6 @@ GCC_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
 PKG_VERSION:=$(firstword $(subst +, ,$(GCC_VERSION)))
 GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 
-ifdef CONFIG_GCC_VERSION_LLVM
-  PKG_SOURCE_VERSION:=c98c494b72ff875884c0c7286be67f16f9f6d7ab
-  PKG_REV:=83504
-  GCC_DIR:=llvm-gcc-4.2-r$(PKG_REV)
-  PKG_VERSION:=4.2.1
-  PKG_SOURCE:=$(GCC_DIR).tar.gz
-  PKG_SOURCE_PROTO:=git
-  PKG_SOURCE_URL:=git://repo.or.cz/llvm-gcc-4.2.git
-  PKG_SOURCE_SUBDIR:=$(GCC_DIR)
-  HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
-else
 ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
     ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
       PKG_REV:=4.5-2012.03
@@ -44,16 +33,16 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_MD5SUM:=0c25f93e15e362e352c933e4649a7fc6
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
-      PKG_REV:=4.6-2012.11
+      PKG_REV:=4.6-2012.12
       PKG_VERSION:=4.6.4
       PKG_VERSION_MAJOR:=4.6
-      PKG_MD5SUM:=d2632b8d3c0e44025dd1c8661db0c201
+      PKG_MD5SUM:=6b6c6a4faa026edd1193cf6426309039
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
-      PKG_REV:=4.7-2012.11
+      PKG_REV:=4.7-2012.12
       PKG_VERSION:=4.7.3
       PKG_VERSION_MAJOR:=4.7
-      PKG_MD5SUM:=590481ff4aff1a9e0f9a206516248877
+      PKG_MD5SUM:=247b15687358bc7958eeb91ab22637d1
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
@@ -66,20 +55,13 @@ else
   ifeq ($(PKG_VERSION),4.4.7)
     PKG_MD5SUM:=295709feb4441b04e87dea3f1bab4281
   endif
-  ifeq ($(PKG_VERSION),4.6.2)
-    PKG_MD5SUM:=028115c4fbfb6cfd75d6369f4a90d87e
-  endif
   ifeq ($(PKG_VERSION),4.6.3)
     PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
   endif
-  ifeq ($(PKG_VERSION),4.7.0)
-    PKG_MD5SUM:=2a0f1d99fda235c29d40b561f81d9a77
-  endif
   ifeq ($(PKG_VERSION),4.7.2)
     PKG_MD5SUM:=cc308a0891e778cfda7a151ab8a6e762
   endif
 endif
-endif
 
 PATCH_DIR=../patches/$(GCC_VERSION)
 
@@ -128,18 +110,15 @@ GCC_CONFIGURE:= \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
-               $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
                $(if $(CONFIG_sparc),--with-long-double-128) \
 
-ifeq ($(CONFIG_GCC_LLVM),)
-  GCC_BUILD_TARGET_LIBGCC:=y
-  GCC_CONFIGURE+= \
+GCC_BUILD_TARGET_LIBGCC:=y
+GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float
-  ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
-    GCC_CONFIGURE += --with-mips-plt
-  endif
+ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+  GCC_CONFIGURE += --with-mips-plt
 endif
 
 ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)