toolchain/gcc: add support for 4.8-linaro
[openwrt/svn-archive/archive.git] / toolchain / gcc / common.mk
index 01fae9836ca66a663ba5cb5cae2d247faad7faf8..2e10f8dbef0574431d84cfd671297e6288c9f2dd 100644 (file)
@@ -26,12 +26,6 @@ PKG_VERSION:=$(firstword $(subst +, ,$(GCC_VERSION)))
 GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 
 ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
-    ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
-      PKG_REV:=4.5-2012.03
-      PKG_VERSION:=4.5.4
-      PKG_VERSION_MAJOR:=4.5
-      PKG_MD5SUM:=0c25f93e15e362e352c933e4649a7fc6
-    endif
     ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
       PKG_REV:=4.6-2012.12
       PKG_VERSION:=4.6.4
@@ -39,10 +33,16 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_MD5SUM:=6b6c6a4faa026edd1193cf6426309039
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
-      PKG_REV:=4.7-2012.12
+      PKG_REV:=4.7-2013.03
       PKG_VERSION:=4.7.3
       PKG_VERSION_MAJOR:=4.7
-      PKG_MD5SUM:=247b15687358bc7958eeb91ab22637d1
+      PKG_MD5SUM:=72e37ed0601f72e4d7e842d7e5373148
+    endif
+    ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
+      PKG_REV:=4.8-2013.04
+      PKG_VERSION:=4.8.1
+      PKG_VERSION_MAJOR:=4.8
+      PKG_MD5SUM:=b6b8195019c7cb93629727ad14eaf7ca
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
@@ -61,11 +61,19 @@ else
   ifeq ($(PKG_VERSION),4.7.2)
     PKG_MD5SUM:=cc308a0891e778cfda7a151ab8a6e762
   endif
+  ifeq ($(PKG_VERSION),4.8.0)
+    PKG_MD5SUM:=e6040024eb9e761c3bea348d1fa5abb0
+  endif
 endif
 
 PATCH_DIR=../patches/$(GCC_VERSION)
 
 BUGURL=https://dev.openwrt.org/
+ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
+  PKGVERSION=OpenWrt/Linaro GCC $(PKG_REV) $(REVISION)
+else
+  PKGVERSION=OpenWrt GCC $(PKG_VERSION) $(REVISION)
+endif
 
 HOST_BUILD_PARALLEL:=1
 
@@ -95,6 +103,8 @@ endif
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(HOST_SOURCE_DIR)/configure \
+               --with-bugurl=$(BUGURL) \
+               --with-pkgversion="$(PKGVERSION)" \
                --prefix=$(TOOLCHAIN_DIR) \
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
@@ -109,11 +119,8 @@ GCC_CONFIGURE:= \
                --with-host-libstdcxx=-lstdc++ \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
-               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
-               $(if $(CONFIG_sparc),--with-long-double-128) \
-
-GCC_BUILD_TARGET_LIBGCC:=y
-GCC_CONFIGURE+= \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
+                       --with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float
@@ -121,7 +128,7 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif
 
-ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6)$(CONFIG_GCC_VERSION_4_7),)
+ifeq ($(CONFIG_GCC_VERSION_4_4),)
   GCC_CONFIGURE+= \
                --with-mpc=$(TOPDIR)/staging_dir/host
 endif
@@ -141,7 +148,9 @@ ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
 endif
 
 ifdef CONFIG_sparc
-  GCC_CONFIGURE+= --enable-targets=all
+  GCC_CONFIGURE+= \
+               --enable-targets=all \
+               --with-long-double-128
 endif
 
 ifeq ($(LIBC),uClibc)