toolchain/gcc: add support for 4.8-linaro
[openwrt/svn-archive/archive.git] / toolchain / gcc / common.mk
index 8305aa9fc14947a20accdf9e0d48a4830836e152..2e10f8dbef0574431d84cfd671297e6288c9f2dd 100644 (file)
@@ -38,6 +38,12 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_VERSION_MAJOR:=4.7
       PKG_MD5SUM:=72e37ed0601f72e4d7e842d7e5373148
     endif
+    ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
+      PKG_REV:=4.8-2013.04
+      PKG_VERSION:=4.8.1
+      PKG_VERSION_MAJOR:=4.8
+      PKG_MD5SUM:=b6b8195019c7cb93629727ad14eaf7ca
+    endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
     GCC_DIR:=gcc-linaro-$(PKG_REV)
@@ -113,7 +119,8 @@ GCC_CONFIGURE:= \
                --with-host-libstdcxx=-lstdc++ \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
-               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
+                       --with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float