gcc: fix newer libstdc++ compile issues with uclibc 0.9.32
[openwrt/svn-archive/archive.git] / toolchain / gcc / common.mk
index ebc5c1e6db068bd62e9d287f93e83962b2508bc7..3a4a94a46afebfdbaacbbfbe0832cbaf1f5ab0c4 100644 (file)
@@ -95,6 +95,9 @@ SEP:=,
 TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
 
 export libgcc_cv_fixed_point=no
+ifdef CONFIG_USE_UCLIBC
+  export glibcxx_cv_c99_math_tr1=no
+endif
 
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \