gcc: remove the bogus CONFIG_TLS_SUPPORT symbol - TLS support is required by libc.
[openwrt/svn-archive/archive.git] / toolchain / gcc / final / Makefile
index e8c32f629dc77af1eeaae99df135cd54ca407905..2c25263db17b9ad419d16baf1441d0d27823fe87 100644 (file)
@@ -15,14 +15,6 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
        --with-libelf=$(TOPDIR)/staging_dir/host
 endif
 
-ifneq ($(CONFIG_TLS_SUPPORT),)
-  GCC_CONFIGURE += \
-       --enable-tls
-else
-  GCC_CONFIGURE += \
-       --disable-tls
-endif
-
 ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
   GCC_CONFIGURE += \
        --enable-sjlj-exceptions