build: add the + token to any commands that can pass through the jobserver, fixes...
[openwrt/svn-archive/archive.git] / toolchain / gcc / final / Makefile
index 1decc951585044291f72e3626de2b7716862e1c7..a667266a0961ad7846c60918a366d7eae3f8ab39 100644 (file)
@@ -3,12 +3,13 @@ GCC_VARIANT:=final
 include ../common.mk
 
 GCC_CONFIGURE += \
+       --with-headers=$(TOOLCHAIN_DIR)/include \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
        --with-slibdir=$(TOOLCHAIN_DIR)/lib
 
-ifneq ($(CONFIG_GCC_VERSION_4_5),)
+ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
   GCC_CONFIGURE += \
        --enable-lto \
        --with-libelf=$(TOPDIR)/staging_dir/host
@@ -22,21 +23,31 @@ else
        --disable-tls
 endif
 
-define Host/Configure
-       mkdir -p $(GCC_BUILD_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
+ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
+  GCC_CONFIGURE += \
+       --enable-sjlj-exceptions
+endif
+
+define CleanupToolchain
+       $(INSTALL_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
        # Important!  Required for limits.h to be fixed.
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        ln -sf ../include $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        ln -sf ../lib $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64)
+endef
+
+define Host/Configure
+       $(CleanupToolchain)
+       mkdir -p $(GCC_BUILD_DIR)
        (cd $(GCC_BUILD_DIR) && rm -f config.cache; \
                $(GCC_CONFIGURE) \
        );
 endef
 
 define Host/Compile
-       $(GCC_MAKE) -C $(GCC_BUILD_DIR) all
+       +$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) all
 endef
 
 define SetupExtraArch
@@ -53,6 +64,7 @@ define SetupExtraArch
 endef
 
 define Host/Install
+       $(CleanupToolchain)
        $(_SINGLE)$(GCC_MAKE) -C $(GCC_BUILD_DIR) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
@@ -65,6 +77,7 @@ define Host/Install
                done; \
        );
        $(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
+       $(SCRIPT_DIR)/patch-specs.sh "$(TOOLCHAIN_DIR)"
 endef
 
 $(eval $(call HostBuild))