build: add the + token to any commands that can pass through the jobserver, fixes...
[openwrt/svn-archive/archive.git] / toolchain / gcc / final / Makefile
index b0fe20023b608c183d2d60dd500276796d0f926d..a667266a0961ad7846c60918a366d7eae3f8ab39 100644 (file)
@@ -28,21 +28,26 @@ ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
        --enable-sjlj-exceptions
 endif
 
-define Host/Configure
-       mkdir -p $(GCC_BUILD_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
+define CleanupToolchain
+       $(INSTALL_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
        # Important!  Required for limits.h to be fixed.
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        ln -sf ../include $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        ln -sf ../lib $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64)
+endef
+
+define Host/Configure
+       $(CleanupToolchain)
+       mkdir -p $(GCC_BUILD_DIR)
        (cd $(GCC_BUILD_DIR) && rm -f config.cache; \
                $(GCC_CONFIGURE) \
        );
 endef
 
 define Host/Compile
-       $(GCC_MAKE) -C $(GCC_BUILD_DIR) all
+       +$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) all
 endef
 
 define SetupExtraArch
@@ -59,6 +64,7 @@ define SetupExtraArch
 endef
 
 define Host/Install
+       $(CleanupToolchain)
        $(_SINGLE)$(GCC_MAKE) -C $(GCC_BUILD_DIR) install
        # Set up the symlinks to enable lying about target name.
        set -e; \