[toolchain]: get rid of gcc 4.1.2 and 4.2.4 support
[openwrt/svn-archive/archive.git] / toolchain / gcc / patches / 4.1.2 / 100-uclibc-conf.patch
index 49d576c7dddc4a65cb9561ceb8abecc4b958802b..48d8e36c08f7c92f1678d27ace042abae8ba1a89 100644 (file)
@@ -1,14 +1,14 @@
---- gcc-4.1.0/gcc/config/t-linux-uclibc
-+++ gcc-4.1.0/gcc/config/t-linux-uclibc
+--- /dev/null
++++ b/gcc/config/t-linux-uclibc
 @@ -0,0 +1,5 @@
 +# Remove glibc specific files added in t-linux
 +SHLIB_MAPFILES := $(filter-out $(srcdir)/config/libgcc-glibc.ver, $(SHLIB_MAPFILES))
 +
 +# Use unwind-dw2-fde instead of unwind-dw2-fde-glibc
 +LIB2ADDEH := $(subst unwind-dw2-fde-glibc.c,unwind-dw2-fde.c,$(LIB2ADDEH))
---- gcc-4.1.0/gcc/config.gcc
-+++ gcc-4.1.0/gcc/config.gcc
-@@ -1887,7 +1887,7 @@ s390x-ibm-tpf*)
+--- a/gcc/config.gcc
++++ b/gcc/config.gcc
+@@ -1884,7 +1884,7 @@ s390x-ibm-tpf*)
        ;;
  sh-*-elf* | sh[12346l]*-*-elf* | sh*-*-kaos* | \
  sh-*-symbianelf* | sh[12346l]*-*-symbianelf* | \
@@ -17,7 +17,7 @@
    sh-*-netbsdelf* | shl*-*-netbsdelf* | sh5-*-netbsd* | sh5l*-*-netbsd* | \
     sh64-*-netbsd* | sh64l*-*-netbsd*)
        tmake_file="${tmake_file} sh/t-sh sh/t-elf"
-@@ -2341,6 +2341,12 @@ m32c-*-elf*)
+@@ -2338,6 +2338,12 @@ m32c-*-elf*)
        ;;
  esac
  
@@ -30,8 +30,8 @@
  case ${target} in
  i[34567]86-*-linux*aout* | i[34567]86-*-linux*libc1)
        tmake_file="${tmake_file} i386/t-gmm_malloc"
---- gcc-4.1.0/boehm-gc/configure
-+++ gcc-4.1.0/boehm-gc/configure
+--- a/boehm-gc/configure
++++ b/boehm-gc/configure
 @@ -4320,6 +4320,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
@@ -44,8 +44,8 @@
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
---- gcc-4.1.0/configure
-+++ gcc-4.1.0/configure
+--- a/configure
++++ b/configure
 @@ -1133,7 +1133,7 @@ no)
      ;;
  "")
@@ -55,8 +55,8 @@
          # Enable libmudflap by default in GNU and friends.
        ;;
      *-*-freebsd*)
---- gcc-4.1.0/configure.in
-+++ gcc-4.1.0/configure.in
+--- a/configure.in
++++ b/configure.in
 @@ -341,7 +341,7 @@ no)
      ;;
  "")
@@ -66,8 +66,8 @@
          # Enable libmudflap by default in GNU and friends.
        ;;
      *-*-freebsd*)
---- gcc-4.1.0/contrib/regression/objs-gcc.sh
-+++ gcc-4.1.0/contrib/regression/objs-gcc.sh
+--- a/contrib/regression/objs-gcc.sh
++++ b/contrib/regression/objs-gcc.sh
 @@ -105,6 +105,10 @@ if [ $H_REAL_TARGET = $H_REAL_HOST -a $H
   then
    make all-gdb all-dejagnu all-ld || exit 1
@@ -79,8 +79,8 @@
  elif [ $H_REAL_TARGET = $H_REAL_HOST ] ; then
    make bootstrap || exit 1
    make install || exit 1
---- gcc-4.1.0/gcc/config/alpha/linux-elf.h
-+++ gcc-4.1.0/gcc/config/alpha/linux-elf.h
+--- a/gcc/config/alpha/linux-elf.h
++++ b/gcc/config/alpha/linux-elf.h
 @@ -27,7 +27,11 @@ Boston, MA 02110-1301, USA.  */
  #define SUBTARGET_EXTRA_SPECS \
  { "elf_dynamic_linker", ELF_DYNAMIC_LINKER },
@@ -93,8 +93,8 @@
  
  #define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax}                \
    %{O*:-O3} %{!O*:-O1}                                                \
---- gcc-4.1.0/gcc/config/arm/linux-elf.h
-+++ gcc-4.1.0/gcc/config/arm/linux-elf.h
+--- a/gcc/config/arm/linux-elf.h
++++ b/gcc/config/arm/linux-elf.h
 @@ -51,7 +51,11 @@
  
  #define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc"
  
  #define LINUX_TARGET_LINK_SPEC  "%{h*} %{version:-v} \
     %{b} \
---- gcc-4.1.0/gcc/config/cris/linux.h
-+++ gcc-4.1.0/gcc/config/cris/linux.h
+--- a/gcc/config/cris/linux.h
++++ b/gcc/config/cris/linux.h
 @@ -73,6 +73,25 @@ Boston, MA 02110-1301, USA.  */
  #undef CRIS_DEFAULT_CPU_VERSION
  #define CRIS_DEFAULT_CPU_VERSION CRIS_CPU_NG
  
  /* Node: Run-time Target */
  
---- gcc-4.1.0/gcc/config/i386/linux.h
-+++ gcc-4.1.0/gcc/config/i386/linux.h
+--- a/gcc/config/i386/linux.h
++++ b/gcc/config/i386/linux.h
 @@ -107,6 +107,11 @@ Boston, MA 02110-1301, USA.  */
  #define LINK_EMULATION "elf_i386"
  #define DYNAMIC_LINKER "/lib/ld-linux.so.2"
  #undef  SUBTARGET_EXTRA_SPECS
  #define SUBTARGET_EXTRA_SPECS \
    { "link_emulation", LINK_EMULATION },\
---- gcc-4.1.0/gcc/config/i386/linux64.h
-+++ gcc-4.1.0/gcc/config/i386/linux64.h
+--- a/gcc/config/i386/linux64.h
++++ b/gcc/config/i386/linux64.h
 @@ -54,14 +54,21 @@ Boston, MA 02110-1301, USA.  */
     When the -shared link option is used a final link is not being
     done.  */
      %{static:-static}}"
  
  /* Similar to standard Linux, but adding -ffast-math support.  */
---- gcc-4.1.0/gcc/config/ia64/linux.h
-+++ gcc-4.1.0/gcc/config/ia64/linux.h
+--- a/gcc/config/ia64/linux.h
++++ b/gcc/config/ia64/linux.h
 @@ -37,13 +37,18 @@ do {                                               \
  /* Define this for shared library support because it isn't in the main
     linux.h file.  */
 +      %{!dynamic-linker:-dynamic-linker " ELF_DYNAMIC_LINKER "}} \
        %{static:-static}}"
  
---- gcc-4.1.0/gcc/config/m68k/linux.h
-+++ gcc-4.1.0/gcc/config/m68k/linux.h
+ #define CPP_SPEC "%{posix:-D_POSIX_SOURCE} %{pthread:-D_REENTRANT}"
+--- a/gcc/config/m68k/linux.h
++++ b/gcc/config/m68k/linux.h
 @@ -123,12 +123,17 @@ Boston, MA 02110-1301, USA.  */
  
  /* If ELF is the default format, we should not use /lib/elf.  */
      %{static}}"
  
  /* For compatibility with linux/a.out */
---- gcc-4.1.0/gcc/config/mips/linux.h
-+++ gcc-4.1.0/gcc/config/mips/linux.h
+--- a/gcc/config/mips/linux.h
++++ b/gcc/config/mips/linux.h
 @@ -105,6 +105,11 @@ Boston, MA 02110-1301, USA.  */
  
  /* Borrowed from sparc/linux.h */
          %{static:-static}}}"
  
  #undef SUBTARGET_ASM_SPEC
---- gcc-4.1.0/gcc/config/pa/pa-linux.h
-+++ gcc-4.1.0/gcc/config/pa/pa-linux.h
+--- a/gcc/config/pa/pa-linux.h
++++ b/gcc/config/pa/pa-linux.h
 @@ -49,13 +49,18 @@ Boston, MA 02110-1301, USA.  */
  /* Define this for shared library support because it isn't in the main
     linux.h file.  */
        %{static:-static}}"
  
  /* glibc's profiling functions don't need gcc to allocate counters.  */
---- gcc-4.1.0/gcc/config/rs6000/linux.h
-+++ gcc-4.1.0/gcc/config/rs6000/linux.h
+--- a/gcc/config/rs6000/linux.h
++++ b/gcc/config/rs6000/linux.h
 @@ -72,7 +72,11 @@
  #define LINK_START_DEFAULT_SPEC "%(link_start_linux)"
  
  
  #define LINK_GCC_C_SEQUENCE_SPEC \
    "%{static:--start-group} %G %L %{static:--end-group}%{!static:%G}"
---- gcc-4.1.0/gcc/config/rs6000/sysv4.h
-+++ gcc-4.1.0/gcc/config/rs6000/sysv4.h
+--- a/gcc/config/rs6000/sysv4.h
++++ b/gcc/config/rs6000/sysv4.h
 @@ -866,6 +866,7 @@ extern int fixuplabelno;
    mcall-linux  : %(link_os_linux)       ; \
    mcall-gnu    : %(link_os_gnu)         ; \
    { "link_os_gnu",            LINK_OS_GNU_SPEC },                     \
    { "link_os_netbsd",         LINK_OS_NETBSD_SPEC },                  \
    { "link_os_openbsd",                LINK_OS_OPENBSD_SPEC },                 \
---- gcc-4.1.0/gcc/config/s390/linux.h
-+++ gcc-4.1.0/gcc/config/s390/linux.h
+--- a/gcc/config/s390/linux.h
++++ b/gcc/config/s390/linux.h
 @@ -77,6 +77,13 @@ Software Foundation, 51 Franklin Street,
  #define MULTILIB_DEFAULTS { "m31" }
  #endif
 +          %{m31:-dynamic-linker " ELF31_DYNAMIC_LINKER "} \
 +          %{m64:-dynamic-linker " ELF64_DYNAMIC_LINKER "}}}}"
  
+ #define CPP_SPEC "%{posix:-D_POSIX_SOURCE} %{pthread:-D_REENTRANT}"
  
- #define TARGET_ASM_FILE_END file_end_indicate_exec_stack
---- gcc-4.1.0/gcc/config/sh/linux.h
-+++ gcc-4.1.0/gcc/config/sh/linux.h
+--- a/gcc/config/sh/linux.h
++++ b/gcc/config/sh/linux.h
 @@ -56,12 +56,21 @@ Boston, MA 02110-1301, USA.  */
  #undef SUBTARGET_LINK_EMUL_SUFFIX
  #define SUBTARGET_LINK_EMUL_SUFFIX "_linux"
  
  /* Output assembler code to STREAM to call the profiler.  */
  
---- gcc-4.1.0/gcc/config/sparc/linux.h
-+++ gcc-4.1.0/gcc/config/sparc/linux.h
+--- a/gcc/config/sparc/linux.h
++++ b/gcc/config/sparc/linux.h
 @@ -125,6 +125,11 @@ Boston, MA 02110-1301, USA.  */
  
  /* If ELF is the default format, we should not use /lib/elf.  */
          %{static:-static}}}"
  
  /* The sun bundled assembler doesn't accept -Yd, (and neither does gas).
---- gcc-4.1.0/gcc/config/sparc/linux64.h
-+++ gcc-4.1.0/gcc/config/sparc/linux64.h
+--- a/gcc/config/sparc/linux64.h
++++ b/gcc/config/sparc/linux64.h
 @@ -162,12 +162,17 @@ Boston, MA 02110-1301, USA.  */
    { "link_arch_default", LINK_ARCH_DEFAULT_SPEC },      \
    { "link_arch",       LINK_ARCH_SPEC },
          %{static:-static}}} \
  "
  
---- gcc-4.1.0/libffi/configure
-+++ gcc-4.1.0/libffi/configure
+--- a/libffi/configure
++++ b/libffi/configure
 @@ -3457,6 +3457,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
---- gcc-4.1.0/libgfortran/configure
-+++ gcc-4.1.0/libgfortran/configure
+--- a/libgfortran/configure
++++ b/libgfortran/configure
 @@ -3699,6 +3699,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
---- gcc-4.1.0/libjava/configure
-+++ gcc-4.1.0/libjava/configure
+--- a/libjava/configure
++++ b/libjava/configure
 @@ -5137,6 +5137,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
---- gcc-4.1.0/libmudflap/configure
-+++ gcc-4.1.0/libmudflap/configure
+--- a/libmudflap/configure
++++ b/libmudflap/configure
 @@ -5382,6 +5382,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
---- gcc-4.1.0/libobjc/configure
-+++ gcc-4.1.0/libobjc/configure
+--- a/libobjc/configure
++++ b/libobjc/configure
 @@ -3312,6 +3312,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
---- gcc-4.1.0/libtool.m4
-+++ gcc-4.1.0/libtool.m4
+--- a/libtool.m4
++++ b/libtool.m4
 @@ -743,6 +743,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;
  netbsd* | knetbsd*-gnu)
    if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
      [lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$']
---- gcc-4.1.0/ltconfig
-+++ gcc-4.1.0/ltconfig
+--- a/ltconfig
++++ b/ltconfig
 @@ -603,6 +603,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-
  
  # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
  netbsd*)
    need_lib_prefix=no
    need_version=no
---- gcc-4.1.0/zlib/configure
-+++ gcc-4.1.0/zlib/configure
+--- a/zlib/configure
++++ b/zlib/configure
 @@ -3426,6 +3426,11 @@ linux-gnu*)
    lt_cv_deplibs_check_method=pass_all
    ;;