brcm2708: fix kmod-sound-soc-bcm2708-i2s config
[openwrt/svn-archive/archive.git] / toolchain / gdb / Makefile
index 6d4c16d926d6c51f16d54a8165c23d5c070b7704..fa5179a5dc524ec11f8ad791f948a99f019b3f95 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,35 +7,30 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_REV:=7.5-2012.12-1
-PKG_VERSION_MAJOR:=7.5
-PKG_VERSION:=linaro-$(PKG_REV)
+PKG_VERSION:=7.8
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=016cf2c5ed06adf7c601e3301a14e370
-PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               gdb_cv_func_sigsetjmp=yes \
-               CFLAGS="-O2" \
-               $(HOST_BUILD_DIR)/configure \
-               --prefix=$(TOOLCHAIN_DIR) \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --disable-werror \
-               $(DISABLE_NLS) \
-               --without-uiout \
-               --disable-tui --disable-gdbtk --without-x \
-               --without-included-gettext \
-               --enable-threads \
-       );
-endef
+HOST_CONFIGURE_VARS += \
+       gdb_cv_func_sigsetjmp=yes
+
+HOST_CONFIGURE_ARGS = \
+       --prefix=$(TOOLCHAIN_DIR) \
+       --build=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
+       --disable-werror \
+       --without-uiout \
+       --disable-tui --disable-gdbtk --without-x \
+       --without-included-gettext \
+       --enable-threads \
+       --with-expat
 
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin