kernel: remove kmod-crypto-aes, AES crypto support is always built into the kernel
[openwrt/svn-archive/archive.git] / toolchain / gdb / Makefile
index b08d76e57ccbebdf5b77d85ce734dceab8a36bb5..fa5179a5dc524ec11f8ad791f948a99f019b3f95 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,33 +7,30 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=linaro-7.2-2011.03-0
+PKG_VERSION:=7.8
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=747b655418058964451eff7c7a15013c
-PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/7.2/7.2-2011.03-0/+download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               gdb_cv_func_sigsetjmp=yes \
-               CFLAGS="-O2" \
-               $(HOST_BUILD_DIR)/configure \
-               --prefix=$(TOOLCHAIN_DIR) \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --disable-werror \
-               $(DISABLE_NLS) \
-               --without-uiout \
-               --disable-tui --disable-gdbtk --without-x \
-               --without-included-gettext \
-               --enable-threads \
-       );
-endef
+HOST_CONFIGURE_VARS += \
+       gdb_cv_func_sigsetjmp=yes
+
+HOST_CONFIGURE_ARGS = \
+       --prefix=$(TOOLCHAIN_DIR) \
+       --build=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
+       --disable-werror \
+       --without-uiout \
+       --disable-tui --disable-gdbtk --without-x \
+       --without-included-gettext \
+       --enable-threads \
+       --with-expat
 
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin