[toolchain] add support for uClibc v0.9.30 (closes: #4271), thanks to Luigi Mantellin...
[openwrt/svn-archive/archive.git] / toolchain / uClibc / Makefile
index 8578ff0a153d56b4b40d4f09b9965735aae66c16..c5771bd5ce56eba937dc27bce2b22cc0fd0e450a 100644 (file)
@@ -39,6 +39,12 @@ ifeq ($(PKG_VERSION),0.9.29)
   endif
 endif
 
+ifeq ($(PKG_VERSION),0.9.30)
+  ifeq ($(PKG_EXTRAVERSION),)
+    PKG_MD5SUM:=e5766e2566e0297adebebbcc0aba1f2d
+  endif
+endif
+
 ifeq ($(PKG_VERSION_SNAPSHOT),y)
   PATCH_DIR:=
   CONFIG_DIR:=./config
@@ -132,7 +138,8 @@ define Build/Prepare
                HOSTCC="$(HOSTCC)" \
                CC="$(TARGET_CC)" \
                CPU_CFLAGS="$(TARGET_CFLAGS)" \
-               pregen install_dev;
+               pregen \
+               $(if $(CONFIG_UCLIBC_VERSION_0_9_28),install_dev,install_headers)
 endef
 
 define Build/Configure