build: decouple the mips16 support flag from the toolchain
[openwrt/svn-archive/archive.git] / toolchain / uClibc / common.mk
index f0a5b3d84fee850aa61826d1189a5979bf496d22..69ac470b029b8a3b94fe2c53543ac258832bad4f 100644 (file)
@@ -45,8 +45,6 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
                        $(if $(CONFIG_MIPS64_ABI),.$(subst ",,$(CONFIG_MIPS64_ABI)), \
                        $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500)))))
 
-TARGET_CFLAGS := $(filter-out -mips16,$(TARGET_CFLAGS))
-
 CPU_CFLAGS = \
        -funsigned-char -fno-builtin -fno-asm \
        --std=gnu99 -ffunction-sections -fdata-sections \