add dependency (needed for parallel build)
[openwrt/svn-archive/archive.git] / tools / Makefile
index eeadde2ed622693f32d30f6f2293ce9bce6bd3b9..03f16b1419ffd1610ed733754484f9c853612953 100644 (file)
@@ -1,67 +1,54 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-
-all: install
-download: $(TARGETS_DOWNLOAD)
-install: 
-       $(MAKE) install-targets
-install-targets: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
-
-squashfs-compile: lzma-install
-
-TOOL_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(TOOL_STAMP_DIR):
-       mkdir -p $@
-
-$(STAGING_DIR)/include-host:
-       @mkdir -p $@
-       @$(CP) ./include/*.h $@/
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
-
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(TOOL_STAMP_DIR) $(STAGING_DIR)/include-host $(TOOL_BUILD_DIR) FORCE
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-compile: %-prepare 
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-install: %-compile
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOL_STAMP_DIR)/.tool_$(patsubst %-clean,%,$@)-*
-
-ifeq ($(MAKECMDGOALS),install-targets)
-MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
-else
-.NOTPARALLEL:
-endif
+curdir:=tools
+
+# subdirectories to descend into
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt autoconf $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
+
+# builddir dependencies
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
+$(curdir)/quilt/compile := $(curdir)/sed/install
+$(curdir)/dtc/compile := $(curdir)/bison/install
+
+# preparatory work
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+       @for dir in $(STAGING_DIR) $(STAGING_DIR_HOST); do ( \
+               set -x; \
+               mkdir -p "$$dir"; \
+               cd "$$dir"; \
+               mkdir -p bin lib include stamp; \
+       ); done
+       mkdir -p $(BUILD_DIR_HOST)/stamp $(BUILD_DIR)/stamp
+       $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
+       touch $@
+
+define PrepareCommand
+$(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
+       @mkdir -p "$$(dir $$@)"; rm -f "$$@"
+       @export FILE="$$$$(which $(2) 2>/dev/null | grep -v 'not found' | head -n1)"; [ -n "$$$$FILE" ] || { \
+               echo "Command $(1) not found."; false; \
+       }; ln -s "$$$$FILE" "$$@"
+
+endef
+
+$(eval $(call PrepareCommand,find,gfind find))
+$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
+$(eval $(call PrepareCommand,cp,gcp cp))
+$(eval $(call PrepareCommand,stat,gstat stat))
+
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
+$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
+
+# prerequisites for the individual targets
+$(curdir)/ := .config prereq
+$(curdir)//install = $(1)/compile
+
+$(eval $(call stampfile,$(curdir),tools,install))
+$(eval $(call subdir,$(curdir)))