squashfs4: add lzma support (kernel support still missing)
[openwrt/svn-archive/archive.git] / tools / Makefile
index 19ee453343b0a7fcbfc9c8018439160853ec41a3..47b5a6ac04261d1078540a3cd30808f55fa2194d 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -12,14 +12,16 @@ curdir:=tools
 tools-y :=
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 tools-y += m4 autoconf automake bison pkg-config sed
-tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 
 tools-$(CONFIG_CCACHE) += ccache
 tools-$(CONFIG_powerpc) += dtc
+tools-dep += lzma
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
+$(curdir)/squashfs4/compile := $(curdir)/lzma/install
 $(curdir)/quilt/compile := $(curdir)/sed/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install