tools: fix GNU stat detection to prevent it from picking up other things named "gstat...
[openwrt/svn-archive/archive.git] / tools / Makefile
index 4fe91f665a1396308717d8a9e5bd6a5096668d9b..48cfbbcc5f93a613fe64fd1716ddb75af0d95a4c 100644 (file)
@@ -101,10 +101,19 @@ $(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
 endef
 endif
 
+$(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
+       @if stat --version > /dev/null 2>&1; then \
+               ln -s `which stat` $@; \
+       elif gstat --version > /dev/null 2>&1; then \
+               ln -s `which gstat` $@; \
+       else \
+               echo "GNU stat not found"; \
+               false; \
+       fi
+
 $(eval $(call PrepareCommand,find,gfind find))
 $(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
 $(eval $(call PrepareCommand,cp,gcp cp))
-$(eval $(call PrepareCommand,stat,gstat stat))
 $(eval $(call PrepareCommand,seq,gseq seq))
 
 $(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat seq)