keynote: fix cflags
[openwrt/svn-archive/archive.git] / tools / Makefile
index 2c093c0aaca67b578a21f01bc72f1038af192150..492c02709909a937becb4f0ee497a6f3b78a5eb4 100644 (file)
@@ -6,8 +6,6 @@
 #
 # Main makefile for the host tools
 #
-
-file:=${lastword ${MAKEFILE_LIST}}
 curdir:=tools
 
 # subdirectories to descend into
@@ -23,13 +21,13 @@ $(STAGING_DIR)/include-host/.done:
        @cp $(1)/include/*.h $$$$(dirname $$@)/
        @touch $$@
 $(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+$(curdir)//compile = $(STAGING_DIR)/include-host/.done
 endef
 $(eval $(call copy_include,$(curdir)))
 
 # prerequisites for the individual targets
-$(curdir)/ := .config
-$(curdir)//compile = $(1)/prepare
+$(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools))
+$(eval $(call stampfile,$(curdir),tools,install))
 $(eval $(call subdir,$(curdir)))