add missing dependencies which broke parallel build
[openwrt/svn-archive/archive.git] / tools / Makefile
index 88755aeadd8b9e7a3be3cfffc8db5f136d35cdbc..72a25b5b0c3b3041e79b66c6c51dd0265ed6dcbe 100644 (file)
@@ -9,14 +9,22 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
+tools-y := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake bison quilt yaffs2
+
+tools-$(CONFIG_CCACHE) += ccache
+tools-$(CONFIG_powerpc) += dtc
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
 $(curdir)/quilt/compile := $(curdir)/sed/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install
-$(curdir)/automake/compile := $(curdir)/m4/install
+$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/mpfr/compile := $(curdir)/gmp/install
+
+$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
+$(curdir)/builddirs-default := $(tools-y)
 
 # preparatory work
 $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
@@ -52,5 +60,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
 $(eval $(call subdir,$(curdir)))