[buildroot] rework aclocal handling, packages have issues writing through the symlink...
[openwrt/svn-archive/archive.git] / tools / Makefile
index 4a39663cdb0dfebfe4d54d01b01789e7f19b03b1..7f22591dcce5eed689a07b9d37407d7fa4e7c92f 100644 (file)
@@ -17,6 +17,7 @@ endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
+tools-y += xorg-macros
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
@@ -46,6 +47,7 @@ $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
+$(curdir)/xorg-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -63,9 +65,6 @@ endef
 # preparatory work
 $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
        $(call PrepareStaging,$(STAGING_DIR))
-       mkdir -p $(STAGING_DIR)/host/share
-       rm -rf $(STAGING_DIR)/host/share/aclocal
-       ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
        mkdir -p $(BUILD_DIR)/stamp
        touch $@