[buildroot] rework aclocal handling, packages have issues writing through the symlink...
[openwrt/svn-archive/archive.git] / tools / Makefile
index 54520bc75ca2eda33e568338e06032ef4e598236..7f22591dcce5eed689a07b9d37407d7fa4e7c92f 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,37 +10,71 @@ curdir:=tools
 
 # subdirectories to descend into
 tools-y :=
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
-tools-y += m4 autoconf automake bison pkg-config sed
-tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage
-tools-y += firmware-utils patch-cmdline quilt yaffs2
-
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5) += gmp mpfr
+tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
+endif
+tools-y += m4 autoconf automake bison pkg-config sed mklibs
+tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
+tools-y += xorg-macros
+tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
+tools-$(CONFIG_TARGET_x86) += qemu
+ifneq ($(CONFIG_TARGET_ar71xx),)
+tools-y += squashfs lzma-old
+endif
+tools-y += squashfs4 lzma
 tools-$(CONFIG_CCACHE) += ccache
-tools-$(CONFIG_powerpc) += dtc
+
+ifdef CONFIG_GCC_USE_GRAPHITE
+  ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
+       tools-y += ppl cloog
+       $(curdir)/cloog/compile := $(curdir)/ppl/install
+  endif
+endif
 
 # builddir dependencies
-$(curdir)/squashfs/compile := $(curdir)/lzma/install
-$(curdir)/quilt/compile := $(curdir)/sed/install
+$(curdir)/pkg-config/compile := $(curdir)/sed/install
+$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
+$(curdir)/squashfs4/compile := $(curdir)/lzma/install
+$(curdir)/quilt/compile := $(curdir)/sed/install $(curdir)/autoconf/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install
 $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/mpc/compile := $(curdir)/gmp/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
+$(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
+$(curdir)/mkimage/compile := $(curdir)/sed/install
+$(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
+$(curdir)/upslug2/compile := $(curdir)/automake/install
+$(curdir)/xorg-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
-# preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
-       @for dir in $(STAGING_DIR) $(STAGING_DIR_HOST); do ( \
+ifndef DUMP_TARGET_DB
+define PrepareStaging
+       @for dir in $(1); do ( \
                set -x; \
                mkdir -p "$$dir"; \
                cd "$$dir"; \
                mkdir -p bin lib include stamp; \
        ); done
-       mkdir -p $(BUILD_DIR_HOST)/stamp $(BUILD_DIR)/stamp
+endef
+
+# preparatory work
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
+       $(call PrepareStaging,$(STAGING_DIR))
+       mkdir -p $(BUILD_DIR)/stamp
+       touch $@
+
+$(STAGING_DIR_HOST)/.prepared: $(TMP_DIR)/.build
+       $(call PrepareStaging,$(STAGING_DIR_HOST))
+       mkdir -p $(BUILD_DIR_HOST)/stamp
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
+
 define PrepareCommand
 $(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
        @mkdir -p "$$(dir $$@)"; rm -f "$$@"
@@ -49,6 +83,7 @@ $(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
        }; ln -s "$$$$FILE" "$$@"
 
 endef
+endif
 
 $(eval $(call PrepareCommand,find,gfind find))
 $(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
@@ -56,12 +91,12 @@ $(eval $(call PrepareCommand,cp,gcp cp))
 $(eval $(call PrepareCommand,stat,gstat stat))
 
 $(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
-$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
-$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion_generic))
 $(eval $(call subdir,$(curdir)))