backfire: [kernel] swconfig: Check vlan/port indexes for validity. (backport of r20811)
[openwrt/svn-archive/archive.git] / tools / Makefile
index 0d91b1f95627f5791d50be151867699eda008335..808ea84129472dbc9c128e832d18812f863a622c 100644 (file)
@@ -10,14 +10,27 @@ curdir:=tools
 
 # subdirectories to descend into
 tools-y :=
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
+endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
-tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
-
+tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
+tools-y += squashfs lzma-old
+else
+ifneq ($(CONFIG_TARGET_ar71xx),)
+tools-y += squashfs lzma-old
+endif
+tools-y += squashfs4 lzma
+endif
 tools-$(CONFIG_CCACHE) += ccache
-tools-$(CONFIG_powerpc) += dtc
-tools-dep += lzma
+
+ifdef CONFIG_GCC_USE_GRAPHITE
+  tools-y += ppl cloog
+  $(curdir)/cloog/compile := $(curdir)/ppl/install
+endif
 
 # builddir dependencies
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
@@ -28,6 +41,8 @@ $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install
 $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
+$(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
+$(curdir)/mkimage/compile := $(curdir)/sed/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -76,5 +91,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion))
 $(eval $(call subdir,$(curdir)))