[tools] add m4 (required for recent auto tools)
[openwrt/svn-archive/archive.git] / tools / Makefile
index 81c69b404f6a4af7bb29147872ac5d45c4ce669f..88755aeadd8b9e7a3be3cfffc8db5f136d35cdbc 100644 (file)
@@ -9,11 +9,14 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf gmp mpfr
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
 $(curdir)/quilt/compile := $(curdir)/sed/install
+$(curdir)/dtc/compile := $(curdir)/bison/install
+$(curdir)/autoconf/compile := $(curdir)/m4/install
+$(curdir)/automake/compile := $(curdir)/m4/install
 
 # preparatory work
 $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
@@ -27,23 +30,21 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-$(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
-       @MD5SUM=`which md5sum 2>/dev/null`; \
-       if [ "$@" != "$$MD5SUM" ]; then \
-               if [ -x "$$MD5SUM" ]; then \
-                       ln -sf "$$MD5SUM" "$@"; \
-               else \
-                       cp $(SCRIPT_DIR)/md5sum $(STAGING_DIR_HOST)/bin/; \
-               fi; \
-       fi
+define PrepareCommand
+$(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
+       @mkdir -p "$$(dir $$@)"; rm -f "$$@"
+       @export FILE="$$$$(which $(2) 2>/dev/null | grep -v 'not found' | head -n1)"; [ -n "$$$$FILE" ] || { \
+               echo "Command $(1) not found."; false; \
+       }; ln -s "$$$$FILE" "$$@"
 
-$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
-       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
-               ln -sf "$(FIND)" $@; \
-       fi
+endef
 
+$(eval $(call PrepareCommand,find,gfind find))
+$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
+$(eval $(call PrepareCommand,cp,gcp cp))
+$(eval $(call PrepareCommand,stat,gstat stat))
 
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)