with no users left, remove support for 2.6.21
[openwrt/svn-archive/archive.git] / tools / Makefile
index 989f3f09759dbb123af5189f3f941c93583d386c..8fc2da3d96a4df5ce0de33a3588036cd6074ac1c 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,32 +9,86 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
+tools-y :=
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
+endif
+tools-y += m4 autoconf automake bison pkg-config sed mklibs
+tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2
+tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
+tools-y += squashfs lzma-old
+else
+ifneq ($(CONFIG_TARGET_ar71xx),)
+tools-y += squashfs lzma-old
+endif
+tools-y += squashfs4 lzma
+endif
+tools-$(CONFIG_CCACHE) += ccache
+
+ifdef CONFIG_GCC_USE_GRAPHITE
+  tools-y += ppl cloog
+  $(curdir)/cloog/compile := $(curdir)/ppl/install
+endif
 
 # builddir dependencies
-$(curdir)/squashfs/compile := $(curdir)/lzma/install
+$(curdir)/pkg-config/compile := $(curdir)/sed/install
+$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
+$(curdir)/squashfs4/compile := $(curdir)/lzma/install
+$(curdir)/quilt/compile := $(curdir)/sed/install
+$(curdir)/dtc/compile := $(curdir)/bison/install
+$(curdir)/autoconf/compile := $(curdir)/m4/install
+$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/mpfr/compile := $(curdir)/gmp/install
+$(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
 
-# preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
-       @for dir in $(STAGING_DIR) $(STAGING_DIR_HOST); do ( \
+$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
+$(curdir)/builddirs-default := $(tools-y)
+
+define PrepareStaging
+       @for dir in $(1); do ( \
                set -x; \
                mkdir -p "$$dir"; \
                cd "$$dir"; \
                mkdir -p bin lib include stamp; \
        ); done
-       mkdir -p $(BUILD_DIR_HOST)/stamp $(BUILD_DIR)/stamp
+endef
+
+# preparatory work
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+       $(call PrepareStaging,$(STAGING_DIR))
+       mkdir -p $(BUILD_DIR)/stamp
+       touch $@
+
+$(STAGING_DIR_HOST)/.prepared: $(TMP_DIR)/.build
+       $(call PrepareStaging,$(STAGING_DIR_HOST))
+       mkdir -p $(BUILD_DIR_HOST)/stamp
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-$(STAGING_DIR_HOST)/bin/find:
-       [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
 
-$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
-$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
+define PrepareCommand
+$(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
+       @mkdir -p "$$(dir $$@)"; rm -f "$$@"
+       @export FILE="$$$$(which $(2) 2>/dev/null | grep -v 'not found' | head -n1)"; [ -n "$$$$FILE" ] || { \
+               echo "Command $(1) not found."; false; \
+       }; ln -s "$$$$FILE" "$$@"
+
+endef
+
+$(eval $(call PrepareCommand,find,gfind find))
+$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
+$(eval $(call PrepareCommand,cp,gcp cp))
+$(eval $(call PrepareCommand,stat,gstat stat))
+
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion))
 $(eval $(call subdir,$(curdir)))