[tools] fix xorg-macros dependency
[openwrt/svn-archive/archive.git] / tools / Makefile
index 5a5c728ab7819f7aba9a53c483ad8fa6537693b8..91f52ff29ac9a51ba36536580ff4dba2614a4287 100644 (file)
@@ -15,18 +15,15 @@ tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5
 tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
-tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
-tools-y += firmware-utils patch-cmdline quilt yaffs2
-tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
+tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
+tools-y += xorg-macros
+tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
-ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
-tools-y += squashfs lzma-old
-else
 ifneq ($(CONFIG_TARGET_ar71xx),)
 tools-y += squashfs lzma-old
 endif
 tools-y += squashfs4 lzma
-endif
 tools-$(CONFIG_CCACHE) += ccache
 
 ifdef CONFIG_GCC_USE_GRAPHITE
@@ -46,10 +43,11 @@ $(curdir)/autoconf/compile := $(curdir)/m4/install
 $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
 $(curdir)/mpc/compile := $(curdir)/gmp/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
-$(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
+$(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
-$(curdir)/qemu/compile := $(curdir)/libuuid/install
+$(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
+$(curdir)/xorg-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -65,8 +63,11 @@ define PrepareStaging
 endef
 
 # preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
        $(call PrepareStaging,$(STAGING_DIR))
+       mkdir -p $(STAGING_DIR)/host/share
+       rm -rf $(STAGING_DIR)/host/share/aclocal
+       ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
        mkdir -p $(BUILD_DIR)/stamp
        touch $@
 
@@ -100,5 +101,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion_generic))
 $(eval $(call subdir,$(curdir)))