[tools] fix xorg-macros dependency
[openwrt/svn-archive/archive.git] / tools / Makefile
index b94ce4b53524cda39125b6983f40584b0944bfb8..91f52ff29ac9a51ba36536580ff4dba2614a4287 100644 (file)
@@ -47,7 +47,7 @@ $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
-$(curdir)/xorg-macros/compile := $(curdir)/autoconf/install
+$(curdir)/xorg-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -63,8 +63,11 @@ define PrepareStaging
 endef
 
 # preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
        $(call PrepareStaging,$(STAGING_DIR))
+       mkdir -p $(STAGING_DIR)/host/share
+       rm -rf $(STAGING_DIR)/host/share/aclocal
+       ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
        mkdir -p $(BUILD_DIR)/stamp
        touch $@