[tools] qemu: build qemu-img for packaging vmdk and vdi images
[openwrt/svn-archive/archive.git] / tools / Makefile
index cad5011c306a6da8ae37b6ab7fbb76601c34ca8e..d7d859075590eb14a06dd8b4237647010f08cf97 100644 (file)
@@ -11,16 +11,14 @@ curdir:=tools
 # subdirectories to descend into
 tools-y :=
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
-ifeq ($(CONFIG_GCC_VERSION_4_5),y)
-tools-$(CONFIG_GCC_VERSION_4_5) += gmp mpfr mpc
-else
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
-endif
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5) += gmp mpfr
+tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
+tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
 tools-y += squashfs lzma-old
 else
@@ -32,8 +30,10 @@ endif
 tools-$(CONFIG_CCACHE) += ccache
 
 ifdef CONFIG_GCC_USE_GRAPHITE
-  tools-y += ppl cloog
-  $(curdir)/cloog/compile := $(curdir)/ppl/install
+  ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
+       tools-y += ppl cloog
+       $(curdir)/cloog/compile := $(curdir)/ppl/install
+  endif
 endif
 
 # builddir dependencies
@@ -47,6 +47,8 @@ $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
 $(curdir)/mpc/compile := $(curdir)/gmp/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
 $(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
+$(curdir)/mkimage/compile := $(curdir)/sed/install
+$(curdir)/upslug2/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)