[ar71xx] tew-632brp: register GPIO buttons
[openwrt/svn-archive/archive.git] / tools / Makefile
index 513ecccb5197db32c2867b8cecbb12ad4636c7b1..ecde1191baffdede062bdd1f6658c10468681d9b 100644 (file)
@@ -1,60 +1,55 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
-TARGETS-$(CONFIG_CCACHE) += ccache
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.tools_installed
-
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP)
-clean: $(TARGETS_CLEAN)
-
-squashfs-compile: lzma-install
-
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
-endif
-
-$(STAMP): $(TOPDIR)/.config
-       mkdir -p $(shell dirname $@)
+curdir:=tools
+
+# subdirectories to descend into
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
+
+# builddir dependencies
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
+$(curdir)/quilt/compile := $(curdir)/sed/install
+
+# preparatory work
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+       @for dir in $(STAGING_DIR) $(STAGING_DIR_HOST); do ( \
+               set -x; \
+               mkdir -p "$$dir"; \
+               cd "$$dir"; \
+               mkdir -p bin lib include stamp; \
+       ); done
+       mkdir -p $(BUILD_DIR_HOST)/stamp $(BUILD_DIR)/stamp
+       $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-TOOL_HOST_INCLUDES:=$(patsubst ./include/%.h,$(STAGING_DIR)/include-host/%.h,$(wildcard ./include/*.h))
-$(TOOL_HOST_INCLUDES): $(STAGING_DIR)/include-host/%.h: ./include/%.h
-       @mkdir -p $(STAGING_DIR)/include-host
-       $(CP) $< $@
+$(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
+       @MD5SUM=`which md5sum 2>/dev/null`; \
+       if [ "$@" != "$$MD5SUM" ]; then \
+               if [ -x "$$MD5SUM" ]; then \
+                       ln -sf "$$MD5SUM" "$@"; \
+               else \
+                       cp $(SCRIPT_DIR)/md5sum $(STAGING_DIR_HOST)/bin/; \
+               fi; \
+       fi
 
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
+$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
+       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
+               ln -sf "$(FIND)" $@; \
+       fi
 
-%-prereq %-download %-clean: FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
-%-prepare: $(TOOL_HOST_INCLUDES) $(TOOL_BUILD_DIR) FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
+$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 
-%-compile: %-prepare FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-       
-%-install: %-compile FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
+# prerequisites for the individual targets
+$(curdir)/ := .config prereq
+$(curdir)//install = $(1)/compile
 
-ifeq ($(MAKECMDGOALS),install-targets)
-MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
-else
-.NOTPARALLEL:
-endif
+$(eval $(call stampfile,$(curdir),tools,install))
+$(eval $(call subdir,$(curdir)))