uclibc: fix the new libpthread implementation on arm
[openwrt/svn-archive/archive.git] / tools / Makefile
index d3dc5ad5f5fa768ba6fc2287edb6ff7834a1a2ae..ecde1191baffdede062bdd1f6658c10468681d9b 100644 (file)
@@ -27,11 +27,25 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-$(STAGING_DIR_HOST)/bin/find:
-       [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+$(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
+       @MD5SUM=`which md5sum 2>/dev/null`; \
+       if [ "$@" != "$$MD5SUM" ]; then \
+               if [ -x "$$MD5SUM" ]; then \
+                       ln -sf "$$MD5SUM" "$@"; \
+               else \
+                       cp $(SCRIPT_DIR)/md5sum $(STAGING_DIR_HOST)/bin/; \
+               fi; \
+       fi
 
-$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
-$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
+$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
+       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
+               ln -sf "$(FIND)" $@; \
+       fi
+
+
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
+$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq