rpcd: iwinfo plugin fixes
[openwrt/svn-archive/archive.git] / tools / ccache / Makefile
index f19c9337fb2c8910dffe4859aa687e9c0b6403fa..76b69577806daa65bfa7d37228f445e039e04343 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,39 +8,28 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=2.4
+PKG_VERSION:=3.1.11
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=73c1ed1e767c1752dd0f548ec1e66ce7
-PKG_CAT:=zcat
+PKG_MD5SUM:=0f6df80c8941d9020a1fd5df5ad57dd7
 
 include $(INCLUDE_DIR)/host-build.mk
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
-  endef
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
 
-  define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
-  endef
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
 
-  define Host/Clean
+define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
-  endef
-else
-  define Host/Prepare
-  endef
-  define Host/Configure
-  endef
-  define Host/Compile
-  endef
-  define Host/Install
-  endef
-  define Host/Clean
-  endef
-endif
+endef
+define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+endef
 
 $(eval $(call HostBuild))