build system refactoring in preparation for allowing packages to do host-build steps
[openwrt/svn-archive/archive.git] / tools / ccache / Makefile
index 50714ad7d9517c6d8e83f937d290f7ba79c3792c..db138c01905e3b558c64ab28a32cefb964784f62 100644 (file)
@@ -18,27 +18,27 @@ PKG_CAT:=zcat
 include $(INCLUDE_DIR)/host-build.mk
 
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+  define Host/Compile
+       $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
   endef
 
-  define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) install
+  define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
   endef
 
-  define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Clean/Default)
+  define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       -$(MAKE) -C $(HOST_BUILD_DIR) clean
+       $(call Host/Clean/Default)
   endef
 else
-  define Build/Prepare
+  define Host/Prepare
   endef
-  define Build/Configure
+  define Host/Configure
   endef
-  define Build/Compile
+  define Host/Compile
   endef
-  define Build/Clean
+  define Host/Clean
   endef
 endif