ar71xx: add preliminary support for the TL-WR841ND v5 board
[openwrt/svn-archive/archive.git] / tools / ccache / Makefile
index 471922c88f103112554786410782eebd49f6b6fc..f19c9337fb2c8910dffe4859aa687e9c0b6403fa 100644 (file)
@@ -18,29 +18,28 @@ PKG_CAT:=zcat
 include $(INCLUDE_DIR)/host-build.mk
 
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+  define Host/Compile
+       $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
   endef
 
-  define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(STAGING_DIR_HOST)" \
-               install
+  define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
   endef
 
-  define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Clean/Default)
+  define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
   endef
 else
-  define Build/Prepare
+  define Host/Prepare
   endef
-  define Build/Configure
+  define Host/Configure
   endef
-  define Build/Compile
+  define Host/Compile
   endef
-  define Build/Clean
+  define Host/Install
+  endef
+  define Host/Clean
   endef
 endif