ar71xx: create images for the WNDR3700, which can be flashed via the factory web...
[openwrt/svn-archive/archive.git] / tools / firmware-utils / Makefile
index b1622369f667220dea38cd16ea072f31b0044136..85ef59509ea33a2d9555f804c3e12c584d494569 100644 (file)
@@ -10,6 +10,8 @@ PKG_NAME := firmware-utils
 
 include $(INCLUDE_DIR)/host-build.mk
 
+include $(INCLUDE_DIR)/kernel.mk
+
 define cc
        $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
 endef
@@ -18,6 +20,11 @@ define cc2
        $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
+define cc3
+       $(CC) $(HOST_CFLAGS) -I$(CURDIR)/../../target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
+endef
+
+
 define Host/Compile
        mkdir -p $(HOST_BUILD_DIR)/bin
        $(call cc,addpattern)
@@ -35,12 +42,18 @@ define Host/Compile
        $(call cc,mkcasfw)
        $(call cc,mkfwimage,-lz)
        $(call cc,mkfwimage2,-lz)
-       $(call cc,imagetag)
+       $(call cc3,imagetag)
        $(call cc,add_header)
        $(call cc,makeamitbin)
        $(call cc,encode_crc)
+       $(call cc,nand_ecc)
        $(call cc2,mkplanexfw sha1)
        $(call cc2,mktplinkfw md5)
+       $(call cc,pc1crypt)
+       $(call cc,osbridge-crc)
+       $(call cc2,wrt400n cyg_crc32)
+       $(call cc,wndr3700)
+       $(call cc,mkdniimg)
 endef
 
 define Host/Install