ar71xx: create images for the WNDR3700, which can be flashed via the factory web...
[openwrt/svn-archive/archive.git] / tools / firmware-utils / Makefile
index e19d63c33d23b897029688b5ac602faedd3f38dd..85ef59509ea33a2d9555f804c3e12c584d494569 100644 (file)
@@ -1,23 +1,32 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host-build.mk
 
 PKG_NAME := firmware-utils
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/firmware-utils
 
-CFLAGS := -O2 -I $(STAGING_DIR)/include-host -include endian.h
+include $(INCLUDE_DIR)/host-build.mk
+
+include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
 endef
 
-define Build/Compile
-       mkdir -p $(PKG_BUILD_DIR)/bin
+define cc2
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+endef
+
+define cc3
+       $(CC) $(HOST_CFLAGS) -I$(CURDIR)/../../target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
+endef
+
+
+define Host/Compile
+       mkdir -p $(HOST_BUILD_DIR)/bin
        $(call cc,addpattern)
        $(call cc,trx)
        $(call cc,motorola-bin)
@@ -28,10 +37,27 @@ define Build/Compile
        $(call cc,srec2bin)
        $(call cc,mkmylofw)
        $(call cc,mkcsysimg)
+       $(call cc,mkzynfw)
+       $(call cc,lzma2eva,-lz)
+       $(call cc,mkcasfw)
+       $(call cc,mkfwimage,-lz)
+       $(call cc,mkfwimage2,-lz)
+       $(call cc3,imagetag)
+       $(call cc,add_header)
+       $(call cc,makeamitbin)
+       $(call cc,encode_crc)
+       $(call cc,nand_ecc)
+       $(call cc2,mkplanexfw sha1)
+       $(call cc2,mktplinkfw md5)
+       $(call cc,pc1crypt)
+       $(call cc,osbridge-crc)
+       $(call cc2,wrt400n cyg_crc32)
+       $(call cc,wndr3700)
+       $(call cc,mkdniimg)
 endef
 
-define Build/Install
-       $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR)/bin
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
 endef
 
 $(eval $(call HostBuild))