[tools] firmware-utils: add a tool to compute crc value for the 5gxi firmware
[openwrt/svn-archive/archive.git] / tools / firmware-utils / Makefile
index 6a0c223c580637c30739e4d79cb66d6ac4d730f8..880a13f94a6ddd59330a7014118c6bf68ca61263 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,23 @@ PKG_NAME := firmware-utils
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
+include $(INCLUDE_DIR)/kernel.mk
+
 define cc
 define cc
-       $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
+endef
+
+define cc2
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
 endef
 
-define Build/Compile
-       mkdir -p $(PKG_BUILD_DIR)/bin
+define cc3
+       $(CC) $(HOST_CFLAGS) -I$(CURDIR)/../../target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
+endef
+
+
+define Host/Compile
+       mkdir -p $(HOST_BUILD_DIR)/bin
        $(call cc,addpattern)
        $(call cc,trx)
        $(call cc,motorola-bin)
        $(call cc,addpattern)
        $(call cc,trx)
        $(call cc,motorola-bin)
@@ -28,10 +39,22 @@ define Build/Compile
        $(call cc,mkcsysimg)
        $(call cc,mkzynfw)
        $(call cc,lzma2eva,-lz)
        $(call cc,mkcsysimg)
        $(call cc,mkzynfw)
        $(call cc,lzma2eva,-lz)
+       $(call cc,mkcasfw)
+       $(call cc,mkfwimage,-lz)
+       $(call cc,mkfwimage2,-lz)
+       $(call cc3,imagetag)
+       $(call cc,add_header)
+       $(call cc,makeamitbin)
+       $(call cc,encode_crc)
+       $(call cc,nand_ecc)
+       $(call cc2,mkplanexfw sha1)
+       $(call cc2,mktplinkfw md5)
+       $(call cc,pc1crypt)
+       $(call cc,osbridge-crc)
 endef
 
 endef
 
-define Build/Install
-       $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
 endef
 
 $(eval $(call HostBuild))
 endef
 
 $(eval $(call HostBuild))