tools/firmware-utils: add seama tool
[openwrt/svn-archive/archive.git] / tools / firmware-utils / Makefile
index c5fbb70cbcfb79cd27055d9f31715c30ae7e3a75..96ccc5ffcf40e272963b3c3431dbb2ca28d6c323 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,24 +9,19 @@ include $(TOPDIR)/rules.mk
 PKG_NAME := firmware-utils
 
 include $(INCLUDE_DIR)/host-build.mk
-
 include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-       $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
-endef
-
-define cc2
-       $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
-
 define Host/Compile
        mkdir -p $(HOST_BUILD_DIR)/bin
        $(call cc,addpattern)
        $(call cc,trx)
        $(call cc,motorola-bin)
        $(call cc,dgfirmware)
+       $(call cc,mkdir615h1 md5)
        $(call cc,trx2usr)
        $(call cc,ptgen)
        $(call cc,airlink)
@@ -38,18 +33,34 @@ define Host/Compile
        $(call cc,mkcasfw)
        $(call cc,mkfwimage,-lz)
        $(call cc,mkfwimage2,-lz)
-       $(call cc2,imagetag)
+       $(call cc,imagetag imagetag_cmdline)
        $(call cc,add_header)
        $(call cc,makeamitbin)
        $(call cc,encode_crc)
        $(call cc,nand_ecc)
-       $(call cc2,mkplanexfw sha1)
-       $(call cc2,mktplinkfw md5)
+       $(call cc,mkplanexfw sha1)
+       $(call cc,mktplinkfw md5)
        $(call cc,pc1crypt)
        $(call cc,osbridge-crc)
-       $(call cc2,wrt400n cyg_crc32)
+       $(call cc,wrt400n cyg_crc32)
        $(call cc,wndr3700)
        $(call cc,mkdniimg)
+       $(call cc,mktitanimg)
+       $(call cc,mkchkimg)
+       $(call cc,mkzcfw cyg_crc32)
+       $(call cc,spw303v)
+       $(call cc,trx2edips)
+       $(call cc,xorimage)
+       $(call cc,buffalo-enc buffalo-lib, -Wall)
+       $(call cc,buffalo-tag buffalo-lib, -Wall)
+       $(call cc,buffalo-tftp buffalo-lib, -Wall)
+       $(call cc,mkwrgimg md5, -Wall)
+       $(call cc,mkedimaximg)
+       $(call cc,mkbrncmdline)
+       $(call cc,mkbrnimg)
+       $(call cc,mkdapimg)
+       $(call cc, mkcameofw, -Wall)
+       $(call cc,seama md5)
 endef
 
 define Host/Install