[tools] firmware-utils/mkplanexfw: new firmware generation tool for the Planex MZK...
[openwrt/svn-archive/archive.git] / tools / firmware-utils / Makefile
index acb429c4438ff06bf1c708e4addb010fa50384c2..e2b6cf4d97dccefa1a6f47e6bea475f52d4272de 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,6 +14,10 @@ define cc
        $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
 endef
 
+define cc2
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+endef
+
 define Build/Compile
        mkdir -p $(PKG_BUILD_DIR)/bin
        $(call cc,addpattern)
@@ -30,7 +34,11 @@ define Build/Compile
        $(call cc,lzma2eva,-lz)
        $(call cc,mkcasfw)
        $(call cc,mkfwimage,-lz)
+       $(call cc,mkfwimage2,-lz)
        $(call cc,imagetag)
+       $(call cc,add_header)
+       $(call cc,makeamitbin)
+       $(call cc2,mkplanexfw sha1)
 endef
 
 define Build/Install