tools/flex: update to 2.6.1
[openwrt/svn-archive/archive.git] / tools / flex / Makefile
index 90082df43e013afbe10de792303779ec6534a10f..78eb1e0b460814f4ab5bb3dc173caab243440c7a 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2008-2014 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,19 +7,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.5.39
+PKG_VERSION:=2.6.1
 
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=77d44c6bb8c0705e0017ab9a84a1502b
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
+PKG_MD5SUM:=cd3c86290fc2676a641aefafeb10848a
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall