mac80211: update to wireless-testing 2010-11-10 + some pending work
[openwrt/svn-archive/archive.git] / tools / genext2fs / Makefile
index 69700ed54bb5bdc941b66adab03f6f9a9dc1c46f..78416f2b3e4fceabe915cae3df53fcc30a4f7a3b 100644 (file)
@@ -4,22 +4,20 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=genext2fs
-PKG_VERSION:=1.4rc1
+PKG_VERSION:=1.4.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=664431bf6737df1c265500e1f0b5d40c
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/genext2fs
+PKG_MD5SUM:=b7b6361bcce2cedff1ae437fadafe53b
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Configure
-       ( cd $(PKG_BUILD_DIR); \
+define Host/Configure
+       ( cd $(HOST_BUILD_DIR); \
                ./configure \
                        --target=$(GNU_HOST_NAME) \
                        --host=$(GNU_HOST_NAME) \
@@ -39,17 +37,17 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) \
                CFLAGS="$(HOST_CFLAGS) -include getline.h" \
                all
 endef
 
-define Build/Install
-       install -m0755 $(PKG_BUILD_DIR)/genext2fs $(STAGING_DIR_HOST)/bin/
+define Host/Install
+       install -m0755 $(HOST_BUILD_DIR)/genext2fs $(STAGING_DIR_HOST)/bin/
 endef
 
-define Build/Clean
+define Host/Clean
        rm -f $(STAGING_DIR_HOST)/bin/genext2fs
 endef